vgmrips

The forum about vgm files
It is currently 2017-12-17, 0:39:34

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 99 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7  Next
Author Message
 Post subject:
PostPosted: 2012-05-20, 11:31:10 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2883
Location: Germany
RichterEX2 wrote:
Another silent one: Paperboy. Plays fine without logging on, however.
These are the bugs I'm searching for!

I noticed that the song doesn't play directly after starting M1. So it won't play at all because I completely reset the game when playing a new song when logging is turned on.
I could probably make an option to disable a proper reset, but I don't like that idea. The actual bug lies somewhere else.


EDIT: Does anyone know where I can get the source code of older M1 versions?

btw: Just noticed that by M1 build is mirrored on Zophar's Domain. :P

EDIT2: The bug is clearly present in a clean and unmodified build of M1 v0.79a1. I'll see if I can play with some of the delay values to make it work, but comparing it to v0.78a6 would be better, since it works fine there.


Top
 Profile  
 
 Post subject:
PostPosted: 2012-05-21, 17:23:07 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 396
Location: Earth Planet
@RichterEX2: You mean that Rollergames has some silence at tracks right? You can use vgm_sptd to separate the silence to the music of VGM file! I doing this in The Simpsons, and it worked! Try yourself!

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Top
 Profile  
 
 Post subject:
PostPosted: 2012-05-22, 11:38:39 

Contributors Contributors
Offline
User avatar

Joined: 2012-01-03, 2:10:28
Posts: 274
Ending of Ghouls'n Ghosts is MAME, but a similar thing happens.

Push F2 and turn on a service mode.
Reset it in spite of F3, and it becomes a service mode.
Choose the input output test.
It becomes the behavior same as M1 when play the No.19 of the sound cord.

It is played normally when let you play No.19 in Input output test after playing other music once.

Probably it does not come to be play normally when do not meet a condition.


Last edited by 2ch-H on 2012-05-22, 11:41:55, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2012-05-30, 8:18:25 

Contributors Contributors
Artists Artists
Offline
User avatar

Joined: 2012-03-30, 9:28:37
Posts: 182
Location: Hagan, GA, USA
I decided to fiddle around with the sound test for a bit. Not sure what I did, but I managed to get the end theme playing properly in MAME. Now I just need to trim it out of the VGM chunk and actually make progress on this game.


Top
 Profile  
 
 Post subject:
PostPosted: 2012-06-02, 19:38:22 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 396
Location: Earth Planet
Another bug: Pontoon and Shadow Dancer don't plays the music with VGM logging enabled (don't tested Desert Breaker, Wally wo Sagase is normal but has tempo problems like Clutch Hitter).

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Top
 Profile  
 
 Post subject:
PostPosted: 2012-06-16, 0:34:45 

Programmers Programmers
Offline

Joined: 2012-06-04, 5:24:46
Posts: 19
Sonic of 8! wrote:
I'll give my "coins" on Ensoniq ES5505 support.


Second that, would allow for Apple IIGS rips in MESS as well ;)


Top
 Profile  
 
 Post subject:
PostPosted: 2012-06-16, 14:11:50 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2883
Location: Germany
Sorry, but I'm currently too busy to take any requests.
And aside from a few bugfixes I didn't work on VGMPlay at all during the last weeks.


Top
 Profile  
 
 Post subject:
PostPosted: 2012-08-12, 2:25:57 
Offline

Joined: 2012-08-12, 1:50:41
Posts: 5
Ninja Baseball Batman has some musical oddities in certain versions of MAME and almost every playthrough on youtube features the garbled music instead of the original music. A youtube viewer notified me of the musical differences yesterday, I loaded up the game in MAME 0.144b (the version he suggested) and the music was completely different to my memory of playing the game in October 2011(I don't remember what version I was using when I first played it), and saved the music using BridgeM1 and uploaded it in '11.

I logged a VGM of the boss theme using M1 in this thread and it sounds all garbled like my previous uploads and all the other videos of the game. nbbatman doesn't seem to have a sound test of any kind, so I'm guessing this is a dead-end for me until M1 can actually play the music properly.

http://www.youtube.com/watch?v=EB4XwPSoYbA Here is how the game should sound.
http://www.youtube.com/playlist?list=PL ... ature=plcp ..in the meantime here's the imperfect Ninja Baseball Batman music. Stages 5-1, 5-2, and 7 sound almost like they should aside from several FM voices sounding like squeaky noises. Something else I was going to mention, but I lost it on the way to the thread. Thanks guys.


Last edited by IREMplay on 2012-08-12, 4:41:01, edited 2 times in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2012-08-12, 3:48:59 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 396
Location: Earth Planet
I don't know the problem, because I don't have the game. But, if I remember, Ninja Baseball Batman has Irem GA20, a custom soundchip made by Irem.

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Top
 Profile  
 
 Post subject:
PostPosted: 2013-05-04, 7:25:18 

Staff Staff
Programmers Programmers
Offline
User avatar

Joined: 2012-04-22, 4:03:45
Posts: 211
Location: New York, NY, USA
Super bump!

ValleyBell, you released an update to MAME & MESS VGM mod after 0.148, but it doesn't seem like M1 has been updated. Will this be taken care of sometime soon?


Top
 Profile  
 
 Post subject:
PostPosted: 2013-05-04, 11:02:25 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2883
Location: Germany
There were no changes regarding VGM logging between MAME 0.144 and 0.148, so there's nothing I can update in M1.
M1 itself hasn't been updated in ages.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-05-04, 22:00:20 

Staff Staff
Programmers Programmers
Offline
User avatar

Joined: 2012-04-22, 4:03:45
Posts: 211
Location: New York, NY, USA
My brother tried to use M1 to VGM rip Haunted Castle and the K051649 data did not get dumped. Is this particular chip a 1.70 chip and is not yet fully supported in the emulator mods or does he simply have an older version of VGMPlay/in_vgm or something?


Last edited by neologix on 2013-05-04, 22:01:48, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2013-05-04, 22:28:54 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 396
Location: Earth Planet
SCC is a 1.61 soundchip. But why you brother did want to log Haunted Castle if the our currently VGM format didn't support K007232 (aka Konami PCM Controller) for drums?

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Top
 Profile  
 
 Post subject:
PostPosted: 2013-05-04, 23:03:45 

Staff Staff
Programmers Programmers
Offline
User avatar

Joined: 2012-04-22, 4:03:45
Posts: 211
Location: New York, NY, USA
Because I confused which of the two K chips was the PCM and gave him incorrect information about what was and wasn't supported.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-05-25, 17:17:33 
Offline

Joined: 2013-05-25, 16:31:02
Posts: 6
In the modded Software itself the tune themselves work on my now old Quad Core 2 Vista PC but the -g command for logging doesn't as I don't see any VGM's going into my wave folder guess Vista PC's can't log which is bummer as I was going to have some fun messing about playing silly buggers with this type of thing.

Arcade > VGM > VGM2MIDI > GXSCC 8|

I'm not really interested in logging full sets in VGM or anything of tunes but I love bollocking about in the GXSCC software with random tunes rather than full sets just for fun.


Last edited by TEOL on 2013-05-25, 17:20:32, edited 1 time in total.

Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 99 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group