vgmrips

The forum about vgm files
It is currently 2017-05-29, 17:24:35

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 269 posts ]  Go to page Previous  1 ... 9, 10, 11, 12, 13, 14, 15 ... 18  Next
Author Message
 Post subject:
PostPosted: 2014-03-12, 0:40:04 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2676
Location: Germany
Okay, finally found time to look at all the bugs. Sorry for being so late.

Despatche's bug has been fixed shortly after he posted. (We discussed this on IRC and I gave him a private build for testing.)

GTheGuardian wrote:
Asura Buster (YMF278B) seems to have some clicks occuring from YMF278B Channel 6.
Fixed. I introduced that bug when porting the YMF278 core from openMSX.

2ch-H wrote:
DPCM sound of the first missing(NSF + NSFPlayer even have occurred).
[...]
Ikari III - Opening
For me the first and second loop sound identical.
In case you mean that the first DPCM sound doesn't have a "click" at the beginning - that's an issue of the sound engine.
When starting the game, the DPCM state begins with sample value 0. Playing a DPCM sound raises and lowers the sample value and due to how the engine works, after every sound it goes up to the maximum value (0x3F). (This looks ugly in a wave editor, btw.)
When playing any DPCM sound, the sample value gets reset from 0x3F to 0, so you hear a click.

I will release an updated VGMPlay/in_vgm in a few weeks.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-13, 0:47:13 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2676
Location: Germany
So here we have VGMPlay/in_vgm 0.40.5 now. (Download from the OP)

Here is an overview of the updates and improvements:
  • fixed not working muting for K053260, K054539 and YMF278B (last one was broken in VGMPlay only)
  • fixed and improved OKIM6258 emulation a bit (mid-song sample rate changes are working now!)
  • fixed a few things in YM2608, YM2612 (CSM mode works now), MAME AY8910, YMF278B, QSound
  • made VGMs that use OKIM6258 or OKIM6295 half as loud by default
For a more detailed, see VGMPlay_Updates.txt

Oh, and support for Famicom Disk System Sound is offical now.

Enjoy!


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-13, 4:52:48 

Contributors Contributors
Artists Artists
Offline
User avatar

Joined: 2012-03-30, 9:28:37
Posts: 180
Location: Hagan, GA, USA
Finding quite a few pops in Akumajou Dracula now.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-13, 15:51:40 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2676
Location: Germany
Okay, after a few hours of trying to get rid of the clicks, I got it working in some way.
That means: VGMs that don't use the Multichannel ADPCM driver should be fine now. The ones that do (like Asuka 120%) still click sometimes.
It won't get any better until I port the OKIM6258 emulation from somewhere else, so you'll need to live with it for now.

Anyway, you can download the slightly updated VGMPlay/in_vgm from the OP now.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-28, 7:14:24 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 399
Location: Earth Planet
Can someone port vgmplay to AndroidOS? I know that already exists VGM Players (Droidsound and DeaDBeeF), but I don't want to be stuck on playing only Sega 8-bit systems and MD VGMs. At least, I want the OPM, OPL series, OPN series, AY, Nintendo PSGs and HuC6280 chips.

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-28, 8:34:21 

Contributors Contributors
Artists Artists
Offline
User avatar

Joined: 2012-03-30, 9:28:37
Posts: 180
Location: Hagan, GA, USA
Well, there is a Mobile version of Foobar2000 in the works, but currently just in planning stages. If that gets done you could use whatever Foobar plugins you want. That being said, I'd like to see a proper port of in_vgm to Foobar. foo_gep doesn't have all the good options like setting the chip samplerates.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-28, 17:27:29 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2676
Location: Germany
You can try to use this Droidsound improvement, which uses VGMPlay (v0.40.4 currently) for playing VGMs.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-04-28, 23:48:04 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 399
Location: Earth Planet
ValleyBell wrote:
You can try to use this Droidsound improvement, which uses VGMPlay (v0.40.4 currently) for playing VGMs.


The packages dosen't seems to install on my device. I use a Android 2.3.5, my device is a Samsung Galaxy Y, maybe it only works on Android 4.0?

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Last edited by Sonic of 8! on 2014-04-28, 23:49:48, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-04, 11:11:27 
Offline
User avatar

Joined: 2012-12-21, 15:30:24
Posts: 53
Location: UK
RichterEX2 wrote:
That being said, I'd like to see a proper port of in_vgm to Foobar. foo_gep doesn't have all the good options like setting the chip samplerates.


Indeed, or possibly a fork of foo_gep. Lots of the soundtracks I download don't play.

_________________
http://iridescentaudio.co.uk


Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-06, 1:31:30 

Staff Staff
Programmers Programmers
Contributors Contributors
Offline
User avatar

Joined: 2014-01-28, 5:51:54
Posts: 446
Am I the only one having trouble muting the FM channels from YM2610?

Code:
[General]
LogSound = 1
SampleRate = 44100
FadeTime = 0
MaxLoops=0x01
[YM2610]
Disabled = False
MuteMask = 65535
MuteMask_FM = 65535
MuteMask_PCM = 65535
MuteFMCh0 = True
MuteFM0 = True
MuteFMCh1 = True
MuteFM1 = True
MuteFMCh2 = True
MuteFM2 = True
MuteFMCh3 = True
MuteFM3 = True
MuteFMCh4 = True
MuteFM4 = True
MuteFMCh5 = True
MuteFM5 = True


This should theoretically generate a null sound, but I can still hear at least one channel. It seems to be FM. Also, MuteFMCh[0-5] seems to have no effect really.

I am running this on some metal slug rips. I'd send you the file but it's big.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-06, 1:52:42 

Staff Staff
Private Eyes Private Eyes
Promoters Promoters
Offline
User avatar

Joined: 2012-02-17, 5:54:01
Posts: 204
Location: USA
I thought Metal Slug used compressed samples instead of FM? Maybe I'm thinking of the later ones though.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-06, 1:54:55 

Staff Staff
Programmers Programmers
Contributors Contributors
Offline
User avatar

Joined: 2014-01-28, 5:51:54
Posts: 446
Metal Slug 1 seems to use FM + samples. Either way, it should still be completely muted.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-06, 7:04:40 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2676
Location: Germany
vampirefrog wrote:
Am I the only one having trouble muting the FM channels from YM2610?


That's what I have and it completely muted Puzzle Bobble and Puzzle De Pon:
Code:
[YM2610]
MuteMask_FM = 0x3F
MuteMask_PCM = 0x7F

If you're using Linux, make sure that the file is named "vgmplay.ini". If it has the name "VGMPlay.ini", it will use the global vgmplay.ini, because its capitalization matches the executable's name. (If it doesn't find anything, it then searches for "VGMPlay.ini".)


Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-06, 10:20:22 

Staff Staff
Programmers Programmers
Contributors Contributors
Offline
User avatar

Joined: 2014-01-28, 5:51:54
Posts: 446
Nope.

http://evo.grigoriada.net/mslug_0022_trimmed.vgm

Code:
[General]
SampleRate = 44100
FadeTime = 0
MaxLoops=0x01
[YM2610]
Disabled = False
MuteMask_FM = 0x3f
MuteMask_PCM = 0x7f


I am still hearing the guitar and some piano.


Top
 Profile  
 
 Post subject:
PostPosted: 2014-05-06, 10:50:31 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2676
Location: Germany
vampirefrog wrote:
I am still hearing the guitar and some piano.
You seriously have no clue how FM sounds.
What you're hearing is the DeltaT channel. (which I accidentally masked out, so you need to use MuteDT)
Additionally, the AY-PSG plays, so you need to disable it to mute it. (And you probably need to re-insert the 58 07 xx command to make the PSG not sound noisy.)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 269 posts ]  Go to page Previous  1 ... 9, 10, 11, 12, 13, 14, 15 ... 18  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group