vgmrips

The forum about vgm files
It is currently 2017-08-22, 22:43:39

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 184 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8, 9, 10 ... 13  Next
Author Message
 Post subject:
PostPosted: 2013-06-04, 13:11:08 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2772
Location: Germany
(Quoted due to pagebreak.)
2ch-H wrote:
I noticed recently.
Code:
B4 11 00    NES APU:   DPCM: Sample Data: 0

Noise seems to occur when there is this command, I think it is good to be able to remove the command in vgm_cmp.

Sorry, forgot about your post.

It's true that this command often causes clicks.
I've seen games use it in various ways (writing 00, writing 7F, writing random values, sometimes initializing the sample), so I don't think always removing it is a good idea.

In most cases though, it's enough to just replace B4 11 00 with B4 11 40.
In the future, I will try to add a declick-feature either to VGMPlay or to one of the tools.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-06-04, 22:20:29 

Staff Staff
Programmers Programmers
Offline
User avatar

Joined: 2012-04-22, 4:03:45
Posts: 203
Location: New York, NY, USA
I've seen posts on this very same NES DPCM click issue on byuu's forums when he started developing his NES emulation. The vast majority of the educated answers seem to point to sound emulation being incomplete in NES emulation in general and blargg and other audio engineering-oriented devs theorize that it was handled with the natural low-pass filtering provided by the analog components.

So first recommendation is to make sure the NES DPCM emulation is accurate; in the VGM mods of the NES players since it's someone else's code that's considerably harder, but for VGMPlay we should strive to have the most accurate sound emulation possible (maybe even that of the recently resurrected Nestopia; check this TASVideos page for NES accuracy test results). The linked test results page says Nintendulator has the most accurate APU and it's open-source so maybe consider that? Second thing is that if the issue isn't in our choice of NES APU core, then we should probably add a toggle for some basic filtering or something for certain chips.

Last resort is to force changing of the command, since this one in particular is a destructive action that also has the potential to completely change the resulting output. Maybe have the console output a warning when someone runs this command telling them it's destructive, possibly allowing removal of the warning via config file editing?


Top
 Profile  
 
 Post subject:
PostPosted: 2013-07-25, 2:27:06 

Contributors Contributors
Offline
User avatar

Joined: 2013-02-08, 2:40:33
Posts: 66
Not sure if this already has been reported but vgm_sro seems to strip some used samples on Mystic Warriors (2xK054539). Example here


Top
 Profile  
 
 Post subject:
PostPosted: 2013-07-25, 10:51:37 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2772
Location: Germany
Bugs with the K054539? No, this isn't known.
Feel always free to report bugs with the tools. If one is reported twice this isn't as bad as if nobody reports it.

EDIT: Okay, I fixed it: vgm_sro_K054539_fix.7z
I didn't handle reverse-playing samples correctly.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-07-25, 11:56:59 

Contributors Contributors
Offline
User avatar

Joined: 2013-02-08, 2:40:33
Posts: 66
Ah thanks, now it does plays okay.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-12-04, 21:41:53 

Contributors Contributors
Offline
User avatar

Joined: 2012-01-03, 2:10:28
Posts: 272
Bugs opt_oki or player or my trimming mistake?

Sharp X68000 Ys III: Wanderers from Ys
"Track 08 Be Careful" and "Track 14 Steeling The Will to Fight" to play in a different sound is OKIM6258 when looping.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-12-04, 23:28:36 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 2772
Location: Germany
It's my fault. opt_oki in its current version has sometimes problems to detect the correct sample when large parts are missing due to the end of the VGM.
I still need to add some code that verifies that the last played sample is correct.

I will fix it with the next pack update batch.


About the GB issues: I haven't had the time to look into it yet.


Top
 Profile  
 
 Post subject:
PostPosted: 2013-12-14, 5:47:11 

Contributors Contributors
Offline
User avatar

Joined: 2012-01-03, 2:10:28
Posts: 272
vgm_cmp bug?
there is a channel that sound There is a delay when using the vgm_cmp.

This VGM sample, Mach Rider - Title:
https://www.dropbox.com/s/pv2xm0wbywspgfr/mrtitle.7z


Last edited by 2ch-H on 2014-01-24, 3:11:29, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2013-12-15, 1:31:36 

Contributors Contributors
Offline
User avatar

Joined: 2012-01-03, 2:10:28
Posts: 272
Another vgm_cmp bug?
sound of the triangle is funny when Using the vgm_cmp.

This VGM sample, Donkey Kong - Hammer:
https://www.dropbox.com/s/hnw5bdl0mtjiuty/dkhammer.7z


Last edited by 2ch-H on 2014-01-24, 3:12:07, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2014-02-20, 11:08:31 

Contributors Contributors
Offline
User avatar

Joined: 2013-02-08, 2:40:33
Posts: 66
Output on Channels 4 and 6 in this log from Gratia: Second Earth seems to be slightly different (and erroneous sounding to me) after running vgm_cmp on the file.
Could this be a bug of vgm_cmp?
https://www.dropbox.com/s/fszqfkmwzjozq ... trimmed.7z


Last edited by GTheGuardian on 2014-02-20, 11:10:06, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2014-03-09, 19:04:54 

Contributors Contributors
Offline
User avatar

Joined: 2012-01-03, 2:10:28
Posts: 272
vgm_trim bug?
ADPCM is silent when I use the vgm_trim.

This VGM sample, The Scheme - Title:
Edit: I delete file.

Code:
vgm_trim -state Scheme_Title.vgm 1393490 0 3807339


Last edited by 2ch-H on 2014-05-03, 12:54:21, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2014-03-10, 7:20:04 

Musicians Musicians
Contributors Contributors
Offline

Joined: 2012-09-29, 11:45:48
Posts: 205
Location: Australia
Two things I notice with the logs:

1. There's NOTHING stored in the ROM data segment for the DeltaT ADPCM to play from.
2. On your trimmed, it looks as if it's streaming DeltaT ADPCM commands to compensate the lack of data stored in ROM. (I wasn't even aware this was possible for the DeltaT as well! :O)

PS: what game is this track from?

_________________
-dj.tuBIG/MaliceX


Last edited by MaliceX on 2014-03-10, 7:26:52, edited 3 times in total.

Top
 Profile  
 
 Post subject:
PostPosted: 2014-03-10, 10:53:31 

Contributors Contributors
Offline
User avatar

Joined: 2012-01-03, 2:10:28
Posts: 272
MaliceX wrote:
PS: what game is this track from?


The Scheme for PC-8801mkIISR Series, Music by Yuzo Koshiro.
http://www.youtube.com/watch?v=BoboFgtpDY0


Top
 Profile  
 
 Post subject:
PostPosted: 2014-03-19, 2:30:56 

Contributors Contributors
Offline
User avatar

Joined: 2011-12-13, 17:31:14
Posts: 397
Location: Earth Planet
Not sure if is a vgm_cmp bug or a conflict with Donkey Kong Land sound driver, but when it drag-and-drop a DKL VGM file on vgm_cmp, the optmized file does not play nothing.

VGM file: https://www.dropbox.com/s/2zgb2ckrvc703 ... %29_03.vgm

_________________
オモいカルチャーをオモチャーと言う - 細野晴臣


Top
 Profile  
 
 Post subject:
PostPosted: 2014-03-19, 4:28:54 

Contributors Contributors
Offline
User avatar

Joined: 2013-02-08, 2:40:33
Posts: 66
Sonic of 8! wrote:
Not sure if is a vgm_cmp bug or a conflict with Donkey Kong Land sound driver, but when it drag-and-drop a DKL VGM file on vgm_cmp, the optmized file does not play nothing.


I checked, it seems that vgm_cmp for removes the "Master Volume" command.
Code:
B3 14 FF    GB DMG:      Master Volume L: 7 = 100%, Volume R: 7 = 100%

This explains why the VGM is mute.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 184 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8, 9, 10 ... 13  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group