vgmrips

The forum about vgm files
It is currently 2020-11-24, 13:59:56

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 320 posts ]  Go to page Previous  1 ... 18, 19, 20, 21, 22
Author Message
 Post subject:
PostPosted: 2020-10-21, 18:15:18 

Contributors Contributors
Staff Staff
Reverse engineers Reverse engineers
Offline
User avatar

Joined: 2013-07-17, 23:32:39
Posts: 449
Could you be more specific? A log of the output when you run "make MACOS=1" would be good. The windows binary should work with wine.


Top
 Profile  
 
 Post subject:
PostPosted: 2020-11-22, 18:08:59 
Offline

Joined: 2016-08-03, 22:36:09
Posts: 28
Location: Italy
Hello,

today, in order to have libvgm player working on Windows 10,
I had to override option(AUDIODRV_XAUDIO2 ... and option(AUDIODRV_WASAPI ... of audio\CMakeLists.txt to cut out both XAUDIO2 and WASAPI
like this
Code:
C:\Users\gzaff\Devs\libvgm\build>cmake -DAUDIODRV_WASAPI=OFF -DAUDIODRV_XAUDIO2=OFF ..
C:\Users\gzaff\Devs\libvgm\build>cmake --build . --config Release

Does anybody have XAUDIO2 and/or WASAPI problem with Windows 10?

Giangiacomo


Top
 Profile  
 
 Post subject:
PostPosted: 2020-11-22, 20:03:24 

Contributors Contributors
Staff Staff
Reverse engineers Reverse engineers
Offline
User avatar

Joined: 2013-07-17, 23:32:39
Posts: 449
what build environment are you using? I generally recommend MinGW-w64 on MSYS2.


Top
 Profile  
 
 Post subject:
PostPosted: 2020-11-22, 23:04:25 
Offline

Joined: 2016-08-03, 22:36:09
Posts: 28
Location: Italy
ctr wrote:
what build environment are you using? I generally recommend MinGW-w64 on MSYS2.

I use Microsoft Visual Studio 2019 Community edition, it has CMake (and git and ninja), so I say MSVC and CMake.


Top
 Profile  
 
 Post subject:
PostPosted: 2020-11-22, 23:16:54 

Staff Staff
Programmers Programmers
Musicians Musicians
Contributors Contributors
Reverse engineers Reverse engineers
Offline
User avatar

Joined: 2011-12-01, 20:20:07
Posts: 3407
Location: Germany
I never had any issues with XAudio2 and WASAPI when building with MSVC 2010 or 2017.
When building with MinGW, WASAPI is disabled due to missing header files.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 320 posts ]  Go to page Previous  1 ... 18, 19, 20, 21, 22

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
[ Time : 0.190s | 15 Queries | GZIP : On ]